Gem 有人和我一样吗?"Ignoring bigdecimal-1.3.2 because its extensions are not built. Try: gem pristine bigdecimal --version 1.3.2"

LisonFan · 2018年09月27日 · 最后由 LisonFan 回复于 2018年09月28日 · 25 次阅读

共收到 8 条回复
pynix 回复

试过了,还是提示

大概是升级ruby版本导致的吧。

brew config 看看用的是哪个 ruby, 然后用对应的目录里的 gem 命令安装个新的 bigdecimal

luikore 回复

切换会系统到 ruby 执行 gem pristine bigdecimal --version 1.3.2 就可以了

不过请教一下 Homebrew 使用到 ruby 能切换吗?

Homebrew 可能会自己下载一个 Ruby, 或者直接就用系统的,都不一定的……

既然用的系统 Ruby, 那你这样就可以了:

sudo /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/bin/gem ins bigdecimal
luikore 回复

嗯嗯,谢谢,昨晚上弄好了

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册