分享 brew install mysql 版本 8 的几点问题的分享

seven.lee · 2018年07月29日 · 最后由 EvanYa 回复于 2018年07月30日 · 1229 次阅读
最近给公司的电脑搭建ruby的开发环境(mac系统),使用brew install mysql的版本是8 gem mysql2版本是0.4.6的时候会有版本冲突问题,解决办法用问题1的方法, 另外参考问题2忘记root密码的解决方法。 数据库管理我用的是navicat,需要使用mysql_native_password重设密码才嫩链接到mysql

问题1 rails gem mysql2版本问题(0.4.6 需要修改mysql.h:188行的参数MYSQL_DEFAULT_AUTH'

问题2 忘记mysql root密码, 
    第一步需要关闭mysql.server stop
    第二步进入mysql的路径mysql/bin下,使用超级权限sudo su
    第三步另开一个终端禁用权限./mysqld_safe --skip-grant-tables &   启动mysql
    第四步进入mysql终端,首先要设置authentication_string为空 update user set authentication_string='' where user='root’, 此时root密码是空的
    第五步退出启动mysql.server start, 使用mysql -u root进入数据库终端, 修改密码policy 通过SHOW VARIABLES LIKE 'validate_password%’;查看, 使用set global validate_password_policy=0; 设置以及其他mysql参数
    最后更新密码 ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY ‘新密码’(注意要使用mysql_native_password,这样navicat才能连接到数据库)
共收到 3 条回复

brew install mysql@5.7

pynix 回复

这个试过,不过我的navicat不知道为啥也连不上,所以最终还是用8的版本处理了

我之前尝试过8,mysql2 gem需要0.5.x

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册